开启左侧

[严重BUG]1.20.1,安装MTR无法启动服务器

[复制链接]
☭雷光兽☭ 2023-7-20 11:17:48
mod在服务器用了客户端的类,也就是说MTR在1.20只能在单人游戏使用,不能在服务器里
& |- t1 q' J# }6 {. d' v0 `- T/ y1 r" {
3 R, G( Z6 u9 o. c9 l
已测试服务端核心:mohist、Forge纯模组服务端、arclight
# Y: f4 r2 j" ]/ ^7 @3 T3 q1 `; u3 b

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有账号?立即注册

×
很简单的道理
如果在一个地区做了一件看似正常的小事(不管是恶意的还是友好的)也能引发轩然大波,足以引起“公愤”,那么该地区社会风气可能仍未稳定

那还是尽早隐居为好
Jeffreyg1228 2023-8-7 16:24:30
本帖最后由 Jeffreyg1228 于 2023-8-7 16:28 编辑 5 Z4 b- i5 Z( A5 o# |$ c9 s0 z
/ ?% i0 F4 ~4 ?) X5 i( N2 D( \
根据 GitHub 用户Jissee,1.20 版本的 Forge API 变化导致服务端初始化时崩溃。参见 https://github.com/jonafanho/Minecraft-Transit-Railway/issues/724https://github.com/jonafanho/Minecraft-Transit-Railway/pull/723
一个可行的解决方案是降级到 1.19.4,或等待官方合并此 PR。
如有条件,也可自行编译以立即修复此问题。若干天后我可能会提供编译后的 JAR 文件。
楼主 ☭雷光兽☭ 2023-8-7 16:33:31
Jeffreyg1228 发表于 2023-8-7 16:24$ T  }2 d/ }9 c
根据 GitHub 用户Jissee,1.20 版本的 Forge API 变化导致服务端初始化时崩溃。参见 https://github.com/jo ...
6 _8 G: N* S7 E2 M4 G) |
好的,等你的修改版
很简单的道理
如果在一个地区做了一件看似正常的小事(不管是恶意的还是友好的)也能引发轩然大波,足以引起“公愤”,那么该地区社会风气可能仍未稳定

那还是尽早隐居为好
Jeffreyg1228 2023-8-10 19:29:48
☭雷光兽☭ 发表于 2023-8-7 16:33
3 E  ~" ~5 U9 A好的,等你的修改版
6 z% d; i: f. a' o
很遗憾,我这边编译不成功。可以等正式版出来,或试试其它方案。
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表